A Microsoft Office (Excel, Word) forum. OfficeFrustration

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » OfficeFrustration forum » Microsoft Office » Setup, Installing & Configuration
Site Map Home Authors List Search Today's Posts Mark Forums Read  

Error 1907. Could not register font. -- while installing Office 07 on Vista



 
 
Thread Tools Display Modes
  #1  
Old June 8th, 2007, 12:14 PM posted to microsoft.public.office.setup
Kaj E. Ozolins
external usenet poster
 
Posts: 2
Default Error 1907. Could not register font. -- while installing Office 07 on Vista

Dear Group,

there's an error with Office 2007 (Enterprise) on Vista (Ultimate) I cannot
workaround:

"Error 1907. Could not register font. Verify that you have sufficient
permissions to install fonts, and that the system supports this font".


I'm able to finish the Installation -- but when it comes to start Excel,
Project or Visio, I get this Error 1907 again (while Word, Outlook, PP,
Access start properly).

My account on this Notebook has Administrator-Rights.

Anyone any suggestion? Thanks much in advance for any help.


Regards,

Kaj

Ads
  #2  
Old June 8th, 2007, 01:22 PM posted to microsoft.public.office.setup
Peter Foldes
external usenet poster
 
Posts: 3,300
Default Error 1907. Could not register font. -- while installing Office 07 on Vista

Error 1907 is an Installer Error . Suggest using the Installer Clean Up Utility and then trying again
http://support.microsoft.com/kb/290301
--
Peter

Please Reply to Newsgroup for the benefit of others
Requests for assistance by email can not and will not be acknowledged.

"Kaj E. Ozolins" wrote in message ...
Dear Group,

there's an error with Office 2007 (Enterprise) on Vista (Ultimate) I cannot
workaround:

"Error 1907. Could not register font. Verify that you have sufficient
permissions to install fonts, and that the system supports this font".


I'm able to finish the Installation -- but when it comes to start Excel,
Project or Visio, I get this Error 1907 again (while Word, Outlook, PP,
Access start properly).

My account on this Notebook has Administrator-Rights.

Anyone any suggestion? Thanks much in advance for any help.


Regards,

Kaj

  #3  
Old June 10th, 2007, 07:56 AM posted to microsoft.public.office.setup
Kaj E. Ozolins
external usenet poster
 
Posts: 2
Default Error 1907. Could not register font. -- while installing Office 07 on Vista

Hi Peter, thanbks for your reply... I will post the results of this
operation immediately after my vacations...

Kaj



"Peter Foldes" schrieb im Newsbeitrag
...
Error 1907 is an Installer Error . Suggest using the Installer Clean Up
Utility and then trying again
http://support.microsoft.com/kb/290301
--
Peter

Please Reply to Newsgroup for the benefit of others
Requests for assistance by email can not and will not be acknowledged.

"Kaj E. Ozolins" wrote in message
...
Dear Group,

there's an error with Office 2007 (Enterprise) on Vista (Ultimate) I
cannot
workaround:

"Error 1907. Could not register font. Verify that you have sufficient
permissions to install fonts, and that the system supports this font".


I'm able to finish the Installation -- but when it comes to start Excel,
Project or Visio, I get this Error 1907 again (while Word, Outlook, PP,
Access start properly).

My account on this Notebook has Administrator-Rights.

Anyone any suggestion? Thanks much in advance for any help.


Regards,

Kaj


  #4  
Old June 12th, 2007, 04:33 AM posted to microsoft.public.office.setup
reneegade
external usenet poster
 
Posts: 1
Default Error 1907. Could not register font. -- while installing Offic

Hi Kaj,

I too have had this problem and found a partial solution today (thanks
Brink). Go to http://www.vistax64.com/tutorials/66...les.html?ltr=S
and run the SCANNOW function - then reboot.

It removed the font problem I was having but not the underlying Office
"Application Configuration Change" that prompted the font error.

Good luck

"Kaj E. Ozolins" wrote:

Hi Peter, thanbks for your reply... I will post the results of this
operation immediately after my vacations...

Kaj



"Peter Foldes" schrieb im Newsbeitrag
...
Error 1907 is an Installer Error . Suggest using the Installer Clean Up
Utility and then trying again
http://support.microsoft.com/kb/290301
--
Peter

Please Reply to Newsgroup for the benefit of others
Requests for assistance by email can not and will not be acknowledged.

"Kaj E. Ozolins" wrote in message
...
Dear Group,

there's an error with Office 2007 (Enterprise) on Vista (Ultimate) I
cannot
workaround:

"Error 1907. Could not register font. Verify that you have sufficient
permissions to install fonts, and that the system supports this font".


I'm able to finish the Installation -- but when it comes to start Excel,
Project or Visio, I get this Error 1907 again (while Word, Outlook, PP,
Access start properly).

My account on this Notebook has Administrator-Rights.

Anyone any suggestion? Thanks much in advance for any help.


Regards,

Kaj


  #5  
Old July 23rd, 2007, 05:38 AM posted to microsoft.public.office.setup
cdl986
external usenet poster
 
Posts: 1
Default Error 1907. Could not register font. -- while installing Offic

I have found what might be termed a work around rather than a solution, after
receiving this same Error 1907 while trying to install Office 2007.

Since the problem is associated with fonts I extracted all the fonts from
the Office 2007 distribution CD and installed them first. Then when the
Error 1907 appeared again clicking on IGNORE allowed the Office 2007
installation to complete, properly.

"reneegade" wrote:

Hi Kaj,

I too have had this problem and found a partial solution today (thanks
Brink). Go to http://www.vistax64.com/tutorials/66...les.html?ltr=S
and run the SCANNOW function - then reboot.

It removed the font problem I was having but not the underlying Office
"Application Configuration Change" that prompted the font error.

Good luck

"Kaj E. Ozolins" wrote:

Hi Peter, thanbks for your reply... I will post the results of this
operation immediately after my vacations...

Kaj



"Peter Foldes" schrieb im Newsbeitrag
...
Error 1907 is an Installer Error . Suggest using the Installer Clean Up
Utility and then trying again
http://support.microsoft.com/kb/290301
--
Peter

Please Reply to Newsgroup for the benefit of others
Requests for assistance by email can not and will not be acknowledged.

"Kaj E. Ozolins" wrote in message
...
Dear Group,

there's an error with Office 2007 (Enterprise) on Vista (Ultimate) I
cannot
workaround:

"Error 1907. Could not register font. Verify that you have sufficient
permissions to install fonts, and that the system supports this font".


I'm able to finish the Installation -- but when it comes to start Excel,
Project or Visio, I get this Error 1907 again (while Word, Outlook, PP,
Access start properly).

My account on this Notebook has Administrator-Rights.

Anyone any suggestion? Thanks much in advance for any help.


Regards,

Kaj


  #6  
Old June 12th, 2008, 03:34 AM posted to microsoft.public.office.setup
bizpubs
external usenet poster
 
Posts: 1
Default Error 1907. Could not register font. -- while installing Office 07 on Vista


The scannow solution probably works. I tried it and got a message
saying that it found errors -- but could not correct them. Check the
log.

Unfortunately -- and here the geniuses who invented Vista's UAC system
are the culprits -- I am not allowed to open the log. (UAC is off, of
course, and I'm sole user/administrator.)

Another triumph of Vista.


--
bizpubs
------------------------------------------------------------------------
bizpubs's Profile: http://forums.techarena.in/member.php?userid=51442
View this thread: http://forums.techarena.in/showthread.php?t=762178

http://forums.techarena.in

  #7  
Old June 18th, 2008, 10:56 PM posted to microsoft.public.office.setup
frustrated
external usenet poster
 
Posts: 279
Default Error 1907. Could not register font. -- while installing Offic

where do I find the scannow solution?

"bizpubs" wrote:


The scannow solution probably works. I tried it and got a message
saying that it found errors -- but could not correct them. Check the
log.

Unfortunately -- and here the geniuses who invented Vista's UAC system
are the culprits -- I am not allowed to open the log. (UAC is off, of
course, and I'm sole user/administrator.)

Another triumph of Vista.


--
bizpubs
------------------------------------------------------------------------
bizpubs's Profile: http://forums.techarena.in/member.php?userid=51442
View this thread: http://forums.techarena.in/showthread.php?t=762178

http://forums.techarena.in


  #8  
Old January 17th, 2009, 01:40 AM posted to microsoft.public.office.setup
Ghent Gunn
external usenet poster
 
Posts: 1
Default Error 1907. Could not register font. -- while installing Office 07 on Vista


I got this message on XP while working with Office 2007.
This is the error message in the Event Viewer:

Event Type: Error
Event Source: MsiInstaller
Event Category: None
Event ID: 11907
Date: 1/16/2009
Time: 4:47:31 PM
User: Acme\User1
Computer: AcmeWorker1
Description:
Product: Microsoft Office Small Business 2007 -- Error 1907.Could not
register font . Verify that you have sufficient permissions to install
fonts, and that the system supports this font.


I found, in my case, this problem was due to the fact that fonts had
been deleted.

At the bottom of this page I list 2 sites that can help you restore the
standard Windows Fonts. In most cases I'm sure that will fix your
problem. If not, you may want to see how I went about fixing my Office
font problem.

Instead of restoring the standard set of fonts, I figured out exactly
which fonts were missing and replaced only those.

Here's how I did it:

Go to Microsoft's SysInternals website and download Process Monitor:
http://technet.microsoft.com/en-us/s.../bb896645.aspx

Run the program after you download it.
The program will start listing activity on your computer. Stop this by
clicking on the magnifying glass so there is a red X over it.
You can also click on File -- Capture Events (Ctrl+E) to do the same
thing.

Then click on the picture of a funnel, or filter.
You can also click on Filter -- Filter (Ctrl+L) to do the same thing.

In the "Process Monitor Filter" screen, click on "Architecture" and
change it to "Path".
Click on "is" and change it to "begins with"

In the next field, an empty field, type the following:

C:\WINDOWS\FONTS\

Click the Add button.
If you have done this correctly there will be a new entry below with a
green checkmark that reads:
Path begins with C:\WINDOWS\FONTS\ Include

Click OK.

Click on Filter -- Drop Filtered Events.

Now we are ready to find the fonts that are required by Office.
Click on the magnifying glass so the red X goes away.
You can also click on File -- Capture Events (Ctrl+E) to do the same
thing.

Now try to launch your Office Application again. When you get to the
error, look near the last line in the Process Monitor list. It will list
the last font that Office tried to access. You will have to replace or
repair this font.
In my case I was able to drag the deleted fonts out of the Recycle bin
and put them back into the C:\WINDOWNS\FONTS\ folder.

This is the list of fonts that was missing from my system (I had
recently tried to clean up my fonts):
REFSAN.TTF
REFSPCL.TTF
CASTELAR.TTF
COPRGTB.TTF
COPRGTL.TTF
PRISTINA.TTF
RAGE.TTF
NIAGENG.TTF
SHOWG.TTF
STENCIL.TTF
VINERITC.TTF
WINGDNG2.TTF
WINGDNG3.TTF


If you do not have a copy of your fonts (they are deleted and gone
forever) you should be able to get the basic fonts back from your
Windows CD.

Here is a website with information on how to restore your standard
fonts:
How to fix Windows XP Font Problems
http://labnol.blogspot.com/2006/03/h...-problems.html

The next link is a Microsoft page about handling fonts.
How to install or remove a font in Windows
http://support.microsoft.com/kb/314960


--
Ghent Gunn
------------------------------------------------------------------------
Ghent Gunn's Profile: http://forums.techarena.in/members/ghent-gunn.htm
View this thread: http://forums.techarena.in/office-setup/762178.htm

http://forums.techarena.in

  #9  
Old April 18th, 2009, 11:32 AM posted to microsoft.public.office.setup
Kronprinz_Adam
external usenet poster
 
Posts: 1
Default Error 1907. Could not register font. -- while installing Office 07 on Vista


Dear friends.
Error 1907 is produced when you delete fonts needed by Office and you
use at the same time the complement "Euroconversion" (*Eurotool.xmla*)
in Excel.

Solution 1 is to disable eurotool (-Click on upper-left round Office
logo - Excel options - Complements).-
Solution 2 fixes the problem and you can use Eurotool again. I have
noticed the error appears when you uninstall the following fonts.

CENTURY.TTF
IMPACT.TTF

So just reinstall them and the problem will be solved.

NOTES:

1. I made a backup of all fonts when I installed Office for the first
time. Just compress the -c:\windows\fonts folder - with Winzip or
Winrar).

2. Other fonts that should be always on the system a ARIAL, VERDANA,
TIMES NEW ROMAN, SEGOE, TREBUCHET, TAHOMA, CAMBRIA, CALIBRI, MTEXTRA,
MICROSS.TTF (Microsoft Sans Serif) and CAMBRIA.TTC

3. Several fonts with the FON extension (they have an icon with a red
"A")
are also essential for Vista. Do not delete any of them!!

4. The file CAMBRIA.TTC (cambria math) is also essential for Word
Equation Editor.

Greetings.
K. Adam


--
Kronprinz_Adam
------------------------------------------------------------------------
Kronprinz_Adam's Profile: http://forums.techarena.in/members/91217.htm
View this thread: http://forums.techarena.in/office-setup/762178.htm

http://forums.techarena.in

  #10  
Old April 24th, 2009, 12:05 AM posted to microsoft.public.office.setup
Tachycardic
external usenet poster
 
Posts: 1
Default Error 1907. Could not register font. -- while installing Office 07 on Vista


Ghent Gunn;4184160 Wrote:
I found, in my case, this problem was due to the fact that fonts had
been deleted.


I signed up specifically to thank you for this. Your fix worked
something miraculous. I knew I had removed some fonts (thankfully I
backed them up - *always back up your fonts!*) but didn't know which
ones Office was complaining about. Thanks!


--
Tachycardic
------------------------------------------------------------------------
Tachycardic's Profile: http://forums.techarena.in/members/93088.htm
View this thread: http://forums.techarena.in/office-setup/762178.htm

http://forums.techarena.in

 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 04:04 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2004-2014 OfficeFrustration.
The comments are property of their posters.